Craft The World Forum

Основной раздел => Общее обсуждение => Тема начата: tmn от 01 Ноябрь 2017, 11:49:53

Название: Почему 1.4.011 нет на GOG?
Отправлено: tmn от 01 Ноябрь 2017, 11:49:53
Это GOG тупит или вы просто про них забыли?

Поддержку Windows XP в 1.4.011 так и не вернули?
Название: Re: Почему 1.4.011 нет на GOG?
Отправлено: Slauq от 01 Ноябрь 2017, 16:29:34
Сегодня уже оправили новое обновление на GOG. Они сами выбирают время когда новое обновление будет доступно. На сколько мне известно никуда поддержку Windows XP не убирали, все должно работать.
Название: Re: Почему 1.4.011 нет на GOG?
Отправлено: tmn от 01 Ноябрь 2017, 18:25:37
На сколько мне известно никуда поддержку Windows XP не убирали, все должно работать.
Спасибо, что ответили. 1.4.009 GOG точно не работает. Тут (https://www.gog.com/forum/craft_the_world/system_error_re_msvcp140dll/post10) человек пишет, что не работает начиная с 1.4.006 из-за Galaxy. У меня та же самая ошибка про QueryFullProcessImageNameA, что описана здесь (https://www.gog.com/forum/general/release_fallout_new_vegas_ultimate_edition_1c381/post160). Но если переименовать Galaxy.dll, то игра не грузится. Сделайте, пожалуйста, загрузку этой библиотеки опциональной (Delay-Loaded DLLs (https://msdn.microsoft.com/en-us/library/151kt790.aspx)). Или, может быть, уже сейчас есть способ запустить игру без Galaxy.dll?

Edit: Самое простое, наверное, — скомпилить дополнительный exe, не слинкованный с Galaxy.
Название: Re: Почему 1.4.011 нет на GOG?
Отправлено: Slauq от 21 Ноябрь 2017, 16:38:32
На сколько мне известно никуда поддержку Windows XP не убирали, все должно работать.
Спасибо, что ответили. 1.4.009 GOG точно не работает. Тут (https://www.gog.com/forum/craft_the_world/system_error_re_msvcp140dll/post10) человек пишет, что не работает начиная с 1.4.006 из-за Galaxy. У меня та же самая ошибка про QueryFullProcessImageNameA, что описана здесь (https://www.gog.com/forum/general/release_fallout_new_vegas_ultimate_edition_1c381/post160). Но если переименовать Galaxy.dll, то игра не грузится. Сделайте, пожалуйста, загрузку этой библиотеки опциональной (Delay-Loaded DLLs (https://msdn.microsoft.com/en-us/library/151kt790.aspx)). Или, может быть, уже сейчас есть способ запустить игру без Galaxy.dll?

Edit: Самое простое, наверное, — скомпилить дополнительный exe, не слинкованный с Galaxy.

Спасибо, передал вашу просьбу программисту.
Название: Re: Почему 1.4.011 нет на GOG?
Отправлено: tmn от 18 Декабрь 2018, 20:07:53
Прошло 3 месяца с релиза 1.4.015 — про GOG опять забыли.

Предположу, что проблему совместимости с Windows XP из-за Galaxy.dll так и не исправили.

Ещё, оказывается, без установленной Galaxy не активируется Dig with Friends и из-за этого не получится одному ходить в биомы. Уберите, пожалуйста, эту обязательную привязку к Galaxy — многие пользователи GOG не устанавливают её из принципиальных соображений.