Автор Тема: Почему 1.4.011 нет на GOG?  (Прочитано 2140 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн tmn

  • Каменщик
  • *
  • Сообщений: 15
  • Карма: 0
    • Просмотр профиля
Почему 1.4.011 нет на GOG?
« : 01 Ноябрь 2017, 11:49:53 »
Это GOG тупит или вы просто про них забыли?

Поддержку Windows XP в 1.4.011 так и не вернули?

Оффлайн Slauq

  • Разработчик
  • Каменщик
  • ******
  • Сообщений: 12
  • Карма: 16
    • Просмотр профиля
Re: Почему 1.4.011 нет на GOG?
« Ответ #1 : 01 Ноябрь 2017, 16:29:34 »
Сегодня уже оправили новое обновление на GOG. Они сами выбирают время когда новое обновление будет доступно. На сколько мне известно никуда поддержку Windows XP не убирали, все должно работать.

Оффлайн tmn

  • Каменщик
  • *
  • Сообщений: 15
  • Карма: 0
    • Просмотр профиля
Re: Почему 1.4.011 нет на GOG?
« Ответ #2 : 01 Ноябрь 2017, 18:25:37 »
На сколько мне известно никуда поддержку Windows XP не убирали, все должно работать.
Спасибо, что ответили. 1.4.009 GOG точно не работает. Тут человек пишет, что не работает начиная с 1.4.006 из-за Galaxy. У меня та же самая ошибка про QueryFullProcessImageNameA, что описана здесь. Но если переименовать Galaxy.dll, то игра не грузится. Сделайте, пожалуйста, загрузку этой библиотеки опциональной (Delay-Loaded DLLs). Или, может быть, уже сейчас есть способ запустить игру без Galaxy.dll?

Edit: Самое простое, наверное, — скомпилить дополнительный exe, не слинкованный с Galaxy.
« Последнее редактирование: 01 Ноябрь 2017, 18:55:30 от tmn »

Оффлайн Slauq

  • Разработчик
  • Каменщик
  • ******
  • Сообщений: 12
  • Карма: 16
    • Просмотр профиля
Re: Почему 1.4.011 нет на GOG?
« Ответ #3 : 21 Ноябрь 2017, 16:38:32 »
На сколько мне известно никуда поддержку Windows XP не убирали, все должно работать.
Спасибо, что ответили. 1.4.009 GOG точно не работает. Тут человек пишет, что не работает начиная с 1.4.006 из-за Galaxy. У меня та же самая ошибка про QueryFullProcessImageNameA, что описана здесь. Но если переименовать Galaxy.dll, то игра не грузится. Сделайте, пожалуйста, загрузку этой библиотеки опциональной (Delay-Loaded DLLs). Или, может быть, уже сейчас есть способ запустить игру без Galaxy.dll?

Edit: Самое простое, наверное, — скомпилить дополнительный exe, не слинкованный с Galaxy.

Спасибо, передал вашу просьбу программисту.
« Последнее редактирование: 23 Апрель 2018, 15:32:13 от Slauq »

Оффлайн tmn

  • Каменщик
  • *
  • Сообщений: 15
  • Карма: 0
    • Просмотр профиля
Re: Почему 1.4.011 нет на GOG?
« Ответ #4 : 18 Декабрь 2018, 20:07:53 »
Прошло 3 месяца с релиза 1.4.015 — про GOG опять забыли.

Предположу, что проблему совместимости с Windows XP из-за Galaxy.dll так и не исправили.

Ещё, оказывается, без установленной Galaxy не активируется Dig with Friends и из-за этого не получится одному ходить в биомы. Уберите, пожалуйста, эту обязательную привязку к Galaxy — многие пользователи GOG не устанавливают её из принципиальных соображений.